Install error
  • RytisRytis April 2012

    Hi Dave,

    I was trying to install xJSFL framework from commit (872de94c70) on Flash CS5.5 on Windows 7 x64 but it failed with empty error in output panel.

    I have tried running Flash as Administrator but it gave no results either. 

    Is there anything I can do with that (taking earlear version or something)?

  • DaveDave April 2012

    Hey Rytis,

    Sorry mate. Development has stalled on the framework in the last few weeks due to heavy client commitments, and it's in a somewhat unstable state.

    If you install from the Beta2b branch, all should run as intended. Although there are lots of changes from the alpha/beta 1, so the docs won't match up.

    That's my next challenge after getting the new (working) Komodo extension out, which I've now been working on again over the last few days.

    Sorry to give you these install hassles...

  • qSheepqSheep March 2013

    Hello Dave,
    this is my first post, sorry for you that this post is in the "Install Error" thread : )

    I tryed to install xJSFL framework from commit (45975fc833) on Flash CS3 (9.0) on Windows XP64, and it failed.

    The output window displays :


               ██  █████ ██████ ██
               ██ ██     ██     ██
      ██ ██    ██  ████  █████  ██
       ███     ██     ██ ██     ██
      ██ ██ ████  █████  ██     █████


      The Rapid-Development Framework for Extending Adobe Flash

      @see licence at

    > xjsfl: INSTALLING xJSFL...
    > xjsfl: loading proxy classes...
    > xjsfl: loading xjsfl...

    > xjsfl: LOADING CORE CLASSES...
    > xjsfl: loading library: Globals

    A la ligne 231 du fichier "install.jsfl" :
    ReferenceError: debug is not defined


    I've tryed on a CS4 version of Flash that I have on a computer too, and it seems to work. But I would prefer to work on CS3 (lighter and less buggy, imho).

    I've tryed to copy some elements (everything displayed in the output window during the install process, concernaning the "configuration folder") from the configuration folder from CS4 to matching folder in CS3 (yeah, I know, it's pretty ugly), but it seems that I missed something.

    At launch in CS3, it seems to work fine (no error:
    > xjsfl: ready!
    ), but when I try to use "xJSFL Sample Module" it doesn't work and the "Call Test()" returns "ReferenceError : JSON is not defined". And nothing is displayed in the output window when I try the 2 other buttons.

    So I begin to think that the best solution would be to have a clean, fonctional installation directly on CS3. (Smart, arn't I ^^). If you have a solution.

    Thanks for your help.


  • DaveDave March 2013

    Ahh... unfortunately, I don't have a copy of CS3 to install!

    If you can get me a copy of the CS3 installer, or an ISO of the CS3 CD which I can install as a trial on a VM, then I can take a look for you :)

  • qSheepqSheep March 2013

    I do have a copy of the CS3 Installer (v9.0 for Windows, trial version, the one Adobe gave when it was CS3 time).
    As I'm french, I thing it's only the french version... But it could still do the job (the menus have the same layouts and orders as in the english version).

    I uploaded it here (the password is "xjsfl"):

    and the update file for v9.0.2 (french) (maybe not very usefull, same password):

    Thanks for your attention.


  • DaveDave March 2013

    Ah, looks like I found the english version online, so I'l try with that :)

  • qSheepqSheep March 2013

    Nice! OK, I understand, softwares are always better with native language : )

  • DaveDave April 2013

    Hey Quentin,

    I finally got round to looking at this, and I've got the framework installing OK. However, once installed, only some of the libraries are being loaded.

    The reason for this lies in one of the core xJSFL functions that helps to work out relative file paths, which is does by traversing the currently executing function file locations. CS3 appears not correctly report this, so there's no way xJSFL can work out where requested file URIs were called from, so no way to work out relative paths.

    Bottom line, therefore, is that the framework isn't going to run on CS3. That's a shame, as I thought it would! Thanks for bringing this to my attention anyway.

    Time to update the docs...

  • qSheepqSheep April 2013

    Hello Dave,

    Thanks a lot to have tried to make it works on CS3. I'm a bit diasppointed it doesn't work, but thanks anyway.

    See you next time.

  • DaveDave April 2013

    It won't be long before CS7 is out, and it's pretty damn quick now it's 64bit. Hopefully that will give you some of the snappiness you want :)

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with OpenID Sign In with Google Sign In with Twitter

Sign In Apply for Membership